i2M:Mixcraft5:Win 7 64 bit: audio, but no midi?

The i2M musicport™ MIDI Converter & Hi-Z USB Audio Interface

i2M:Mixcraft5:Win 7 64 bit: audio, but no midi?

Postby studleylee » Fri Mar 30, 2012 5:53 pm

Hi,
I must be doing something wrong :shock: : MySetup:
i2M
Mixcraft5
Windows7 64 bit:
When I create a new track for a virtual instrument, I can't seem to get the i2M to control it.
I can use the USB audio interface portion to hear the guitar in a 'regular'track.
I downloaded and installed both 32 and 64 bit( i2M-musicport-ASIO-x64.msi, i2M-musicport-ASIO.msi),

I used SonuusFirmwareUpdater.msi to update the firmware to i2Mmusicport_1_0200.sfu.
The i2M-musicport communicates and show the current firmware and the unit LEDs indicates all the color/modes, and clipping, as expected.

The youtube videos show it pluggin-and-playing, but not for me so far. I must be doing something simply wrong?

I'm a programmer and embedded guy, so not too stupid :-) currently I'm trying Simple USB Logger v.1.0 http://www.incentivespro.com with the i2m toggling the latency test to see if midi packets are actually getting to the system, first time I've used this or tried to decode usb-midi packets so still learning to recognize the protocol.
Thanks -Lee
studleylee
 
Posts: 5
Joined: Fri Mar 30, 2012 5:36 pm

Re: i2M:Mixcraft5:Win 7 64 bit: audio, but no midi?

Postby studleylee » Fri Mar 30, 2012 7:16 pm

Also, Is there a simple app might show midi status of a USB-MIDI messages being sent from the i2M into the system?
studleylee
 
Posts: 5
Joined: Fri Mar 30, 2012 5:36 pm

Re: i2M:Mixcraft5:Win 7 64 bit: audio, but no midi?

Postby studleylee » Sat Mar 31, 2012 2:54 am

This is tech support for Sonuus? I'm jumpin for joy at the response so far.
studleylee
 
Posts: 5
Joined: Fri Mar 30, 2012 5:36 pm

Re: i2M:Mixcraft5:Win 7 64 bit: audio, but no midi?

Postby studleylee » Sat Mar 31, 2012 7:24 am

Just logging my own findings in case someone needs some support on this.

ok, I've verified that sonuus i2m is sending valid midi from its driver using MME. Now I'm yelling at MixCraft as to why the x64 version is not processing them.
studleylee
 
Posts: 5
Joined: Fri Mar 30, 2012 5:36 pm

Re: i2M:Mixcraft5:Win 7 64 bit: audio, but no midi?

Postby james » Sat Mar 31, 2012 10:18 am

To verify MIDI operation, we recommend Midi-Ox (http://www.midiox.com/) (This site was off-line for a few weeks, but seems to be back up again.)

I'm not sure what the problem with MixCraft is. We've not tested the 64-bit version, but did test the 32-bit version a while ago and I don't recall any issues. I don't have either version currently installed, so I can't check here right now.

I suspect the problem is either that the i2M MIDI hasn't been selected as a MIDI input device, or that a track hasn't been selected to have the i2M MIDI as it's source (Note that the i2M transmits on MIDI channel 0).
User avatar
james
Site Admin
 
Posts: 961
Joined: Fri Jun 06, 2008 8:12 pm

FIXED: Re: i2M:Mixcraft5:Win 7 64 bit: audio, but no midi?

Postby studleylee » Sat Mar 31, 2012 8:28 pm

My humble apologies for grumping at Sonuus: the issue is in the hands of Mixcraft5 and Microsoft's vagueness
on accessing( thunking ) x64 drivers and services

FIXED Myself 8) : NOW I will buy Mixcraft5 and 6 as I love it!!!!

Relevant reading:
http://msdn.microsoft.com/en-us/magazine/cc300794.aspx

If running a x64 bit version of windows and using 32bit programs for audio DAW:
Goto the following location "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}
rmouse to add a new Mulit-String-Value, type in the name UpperFilers then hit enter, then double click this new UpperFilers
an in the data field type: ksthunk

This Microsoft Kernel Audio Driver "Kernel Streaming WOW Thunk Service" or
ksthunk.sys to be used prior to the x64 bit Kernel Audio Driver so that it can
be accessed by Win32programs lik MixCraft. It's a 32bit vs 64bit pointer issue.

reg data results.
"UpperFilters"=hex(7):6b,00,73,00,74,00,68,00,75,00,6e,00,6b,00,00,00,00,00

Thanks and I hope this helps you guys!
-Lee Studley
studleylee
 
Posts: 5
Joined: Fri Mar 30, 2012 5:36 pm

Re: i2M:Mixcraft5:Win 7 64 bit: audio, but no midi?

Postby james » Sun Apr 01, 2012 9:31 am

Lee, many thanks that is very useful indeed.

I didn't know about that, and I wonder how many others don't either! Quite why it's so hidden is anyone's guess.
User avatar
james
Site Admin
 
Posts: 961
Joined: Fri Jun 06, 2008 8:12 pm


Return to i2M musicport™ Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron