Page 1 of 1

No output (direct or otherwise) - Windows 10/Reaper

PostPosted: Mon Apr 16, 2018 7:15 pm
by Sinnerboy89
Hi there,
I'm using Reaper on Windows 10 64-bit, with my guitar plugged into i2m musicport. Reaper's audio system is set to ASIO, with i2m musicport ASIO as the driver, and inputs and outputs are as you expect (Hi-Z input and chained output). ASIO config chained output device only as WASAPI available, the other two are greyed out (not sure why). Input Monitor level is set to max, and even with track armed and direct monitoring switched on in Reaper, I hear nothing - however meter is reading signal, and I can record. How can I turn monitoring on, or what's gone wrong here?

Thanks,
Chris

Re: No output (direct or otherwise) - Windows 10/Reaper

PostPosted: Tue Apr 17, 2018 8:37 am
by james
Hi Chris,

I'm not sure why you're not hearing anything. What you described sounds like everything is configured correctly.

On the i2M ASIO control panel, "Input Monitor" will pass the input straight to the output without requiring the host (i.e., Reaper) to have monitoring enabled. One thing to try is to disable either the Input Monitor on the ASIO panel, or the input metering in Reaper, just in case they are cancelling each other out (though they should be in phase so this shouldn't happen).

Perhaps the i2M ASIO driver is having problems with the WASAPI device you are using. Two things to try: (1) adjust the buffer size used by the WASAPI device (2) it might be worth trying ASIO4ALL (http://www.asio4all.org/), for some devices this might work better than the i2M ASIO driver. The i2M MIDI will still function without the i2M ASIO driver being used.

FYI: The other options on the chained output are greyed because the ASIO driver didn't find any suitable devices that it could open; it only found your WASAPI device.

Re: No output (direct or otherwise) - Windows 10/Reaper

PostPosted: Tue Apr 17, 2018 9:29 am
by Sinnerboy89
Hi James,
Maybe not surprisingly, turning off either Reaper output or input monitoring from ASIO control panel changes nothing :)

Whilst I can control input buffer size in control panel, there is no option to change WASAPI buffer size (the drop down is empty) - this must need to be kept identical to input buffer size? Either way, fiddling with that changes nothing except maybe that latency is affected elsewhere...

I did try ASIO4ALL before posting, apologies for not mentioning that - this was mainly because apart from rendering ASIO as an option for chained output on ASIO control panel, it also had no success.

Puzzling!

I've also checked monitoring in Audacity, and similar is happening.

FWIW, I do hear output with WaveOut, but there's considerabe lag/latency with this option.

Re: No output (direct or otherwise) - Windows 10/Reaper

PostPosted: Tue Apr 17, 2018 9:46 am
by james
Hi Chris,

The buffer size should be able to be changed on the Chained output device. Perhaps the fact that this can't be selected is an indication of a problem with the WASAPI device in some way. If the buffer size can't be changed it possibly means the i2M ASIO driver can't correctly open that device, hence no audio output. It's not something I've seen before, so I don't know for sure what's happening here.

The fact ASIO4ALL doesn't work is also strange: in most cases both the i2M ASIO and ASIO4ALL works, in rare cases only one works. Is there anything else running that's using the WASAPI device that's preventing it working with another application?