Software improvement suggestions

For the Wahoo™ Dual-Analogue, Digitally-Controlled Wah/Filter Pedal

Moderators: johnmc, james

Re: Software improvement suggestions

Postby james » Mon Aug 25, 2014 4:30 pm

The Wahoo uses class-compliant USB. This means it doesn't need a special driver, but it still needs to use the driver built-in to the operating system. So, when you first connect a Wahoo (or other Sonuus USB product) to your computer it will ask to install drivers. Allow this to happen so you can use it. If you connect to a different USB port, it may ask you again for drivers. This is normal.
User avatar
james
Site Admin
 
Posts: 1861
Joined: Fri Jun 06, 2008 8:12 pm

Re: Software improvement suggestions

Postby Flop54 » Mon Aug 25, 2014 6:45 pm

Sorry!! It's just my computer!! It's work perfectly!
Flop54
 
Posts: 122
Joined: Sat Apr 13, 2013 2:57 pm

Re: Software improvement suggestions

Postby james » Mon Aug 25, 2014 6:50 pm

Great! :D
User avatar
james
Site Admin
 
Posts: 1861
Joined: Fri Jun 06, 2008 8:12 pm

Re: Software improvement suggestions

Postby Flex » Wed Sep 03, 2014 4:14 pm

The pitch tracking mode is really unadapted to bass guitar, and even when I invert the frequencies it does not change anything at all...
I'm disapointed about the poor development about this marvelous FX pedals... Analog sound with digital control the future of sound for our instruments but it need to be better developed...
Flex
 
Posts: 17
Joined: Fri Nov 08, 2013 10:18 pm

Re: Software improvement suggestions

Postby james » Wed Sep 03, 2014 4:24 pm

Pitch tracking works very well with bass, maybe you have something set wrongly?

For lowest frequency tracking, make sure "instrument" is set to "4-string bass" or "5-string bass" in the setup |settings page of the editor.

If you still have problems, post your preset file here and we'll look to see why its not working.
User avatar
james
Site Admin
 
Posts: 1861
Joined: Fri Jun 06, 2008 8:12 pm

Re: Software improvement suggestions

Postby Flop54 » Sun Sep 07, 2014 10:44 am

I test today the wahoo!
Good news the midi sync work with the wahoo and the step mode is really better with your update! I find a little bug when i change div'n the new parametre is changed but if i change div'n with the pedal parameter on, i have to push and hold the pedal to hear the difference.
When i save a preset, is it normal that the destination preset stay empty when i choose him. I think it was not like this before it's too bad because if they are wrong and we choose a preset bad we did not realize. it's the same on the voluum!
Similarly I find it unfortunate that is not a message when you save a preset to another.
wahoo.png
wahoo.png (10.07 KiB) Viewed 7646 times
Flop54
 
Posts: 122
Joined: Sat Apr 13, 2013 2:57 pm

Re: Software improvement suggestions

Postby james » Tue Sep 09, 2014 4:46 pm

I find a little bug when i change div'n the new parameter is changed but if i change div'n with the pedal parameter on, i have to push and hold the pedal to hear the difference.


I can't reproduce this, or I misunderstand what you mean. If I set the div to be pedal controlled with lo = "x1" and hi = "x2", then at around half-way the div changes between x1 and x2.

When i save a preset, is it normal that the destination preset stay empty when i choose him. I think it was not like this before it's too bad because if they are wrong and we choose a preset bad we did not realize. it's the same on the voluum!


This is a bug, and a strange one. It didn't do this in the debug test builds of the editor. And it doesn't seem to be doing it in the latest release builds. I have not been able to reproduce it, other than in the installer version. I can only assume there was a problem with the build when the last installers were built. In that case, it should be fixed in the next update. The Voluum editor is the same (both editors have had similar updates).

Similarly I find it unfortunate that is not a message when you save a preset to another.


This would be nice. The problem is the editor doesn't know if you have something saved in the target preset or not. It has no concept of "empty preset". However, it could use the short name "---" as an indication that nothing is stored there and not issue the warning in this case. I think that would be good enough.
User avatar
james
Site Admin
 
Posts: 1861
Joined: Fri Jun 06, 2008 8:12 pm

Re: Software improvement suggestions

Postby Flop54 » Tue Sep 09, 2014 5:51 pm

james wrote:I can't reproduce this, or I misunderstand what you mean. If I set the div to be pedal controlled with lo = "x1" and hi = "x2", then at around half-way the div changes between x1 and x2.


No it's not that.
If i change the div when the check box pedal is set off i hear the change directly. it's ok!
If i change the div low when the check box is set on and the pedal is in low position. I have to move the pedal in high position and return it in low position to hear the change.

james wrote:This is a bug, and a strange one. It didn't do this in the debug test builds of the editor. And it doesn't seem to be doing it in the latest release builds. I have not been able to reproduce it, other than in the installer version. I can only assume there was a problem with the build when the last installers were built. In that case, it should be fixed in the next update. The Voluum editor is the same (both editors have had similar updates).
ok

james wrote:This would be nice. The problem is the editor doesn't know if you have something saved in the target preset or not. It has no concept of "empty preset". However, it could use the short name "---" as an indication that nothing is stored there and not issue the warning in this case. I think that would be good enough.
yes it can be a good idea.
Flop54
 
Posts: 122
Joined: Sat Apr 13, 2013 2:57 pm

Re: Software improvement suggestions

Postby james » Tue Sep 09, 2014 7:59 pm

No it's not that.
If i change the div when the check box pedal is set off i hear the change directly. it's ok!
If i change the div low when the check box is set on and the pedal is in low position. I have to move the pedal in high position and return it in low position to hear the change.


Yes, I understand.

The applied div does update immediately when editing on the Wahoo's control panel. And I have confirmed it doesn't do so on the editor. The reason is subtle, and it is hard to change this. The firmware knows when the div parameter has been changed when the control panel is used, but always know which parameter has changed when the editor is used. Updating the div is not like updating some other parameters and needs to be done carefully.

In other words, it's not a simple fix, unfortunately.
User avatar
james
Site Admin
 
Posts: 1861
Joined: Fri Jun 06, 2008 8:12 pm

Re: Software improvement suggestions

Postby Flop54 » Tue Sep 09, 2014 8:26 pm

james wrote:In other words, it's not a simple fix, unfortunately.


Ok i understand. It's not a big problem.

Like i ask you in the voluum section what about a phase knob for midi sync mode is it possible.. And sorry to be so obstinate but what about the two lfo in parallele? ;)
Flop54
 
Posts: 122
Joined: Sat Apr 13, 2013 2:57 pm

PreviousNext

Return to Wahoo™ Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron